p PatchFirst

PatchFirst · Latest vulnerabilities

mercurius vulnerabilities

Vulnerabilities published for mercurius in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 4

  1. CVE-2026-30241

    Low · CVSS 2.7EPSS 0.4%Fix available

    Mercurius: queryDepth limit bypassed for WebSocket subscriptions

    Mercurius is a GraphQL adapter for Fastify. Prior to version 16.8.0, Mercurius fails to enforce the configured queryDepth limit on GraphQL subscription queries received over WebSocket connections. The depth check is correctly applied to HTTP queries and mutations, but subscription queries are parsed and executed without invoking the depth validation. This allows a remote client to submit arbitrarily deeply nested subscription queries over WebSocket, bypassing the intended depth restriction. On schemas with recursive types, this can lead to denial of service through exponential data resolution on each subscription event. This issue has been pa

    • Update to 16.8.0
    Published Updated
  2. CVE-2025-64166

    Medium · CVSS 5.4EPSS 0.18%Fix available

    Mercurius: Incorrect Content-Type parsing can lead to CSRF attack

    Mercurius is a GraphQL adapter for Fastify. Prior to version 16.4.0, a cross-site request forgery (CSRF) vulnerability was identified. The issue arises from incorrect parsing of the Content-Type header in requests. Specifically, requests with Content-Type values such as application/x-www-form-urlencoded, multipart/form-data, or text/plain could be misinterpreted as application/json. This misinterpretation bypasses the preflight checks performed by the fetch() API, potentially allowing unauthorized actions to be performed on behalf of an authenticated user. This issue has been patched in version 16.4.0.

    • Update to 16.4.0
    Published Updated
  3. CVE-2023-22477

    Medium · CVSS 5.3EPSS 1.09%Fix available

    Mercurius is vulnerable to denial of service (DoS) when using subscriptions

    Mercurius is a GraphQL adapter for Fastify. Any users of Mercurius until version 10.5.0 are subjected to a denial of service attack by sending a malformed packet over WebSocket to `/graphql`. This issue was patched in #940. As a workaround, users can disable subscriptions.

    • Update to 11.5.0
    • Update to 8.13.2
    Published Updated
  4. CVE-2021-43801

    High · CVSS 7.5EPSS 1.57%Fix available

    Uncaught Exception in mercurius

    Mercurius is a GraphQL adapter for Fastify. Any users from [email protected] to 8.11.1 are subjected to a denial of service attack by sending a malformed JSON to `/graphql` unless they are using a custom error handler. The vulnerability has been fixed in https://github.com/mercurius-js/mercurius/pull/678 and shipped as v8.11.2. As a workaround users may use a custom error handler.

    • Update to 8.11.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →