p PatchFirst

PatchFirst · Latest vulnerabilities

opencc vulnerabilities

Vulnerabilities published for opencc in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 3

  1. GHSA-7fqq-q52p-2jjg

    Medium · CVSS 6.5Fix available

    OpenCC has an Out-of-bounds read when processing truncated UTF-8 input

    ### Summary OpenCC versions before 1.2.0 contain two `CWE-125: Out-of-bounds Read` issues caused by length validation failures in UTF-8 processing. When handling malformed or truncated UTF-8 input, OpenCC trusted derived length values without enforcing the invariant that processed length must not exceed the remaining input buffer. This could result in out-of-bounds reads during segmentation or conversion. ### Details Two independent code paths in OpenCC failed to enforce the invariant: `matchedLength <= remainingLength` Both paths assumed derived length values were valid and within input bounds, but did not validate that assumption again

    • Update to 1.2.0
    Published Updated
  2. CVE-2025-15536

    Medium · CVSS 4.8EPSS 0.25%Fix available

    BYVoid OpenCC MaxMatchSegmentation.cpp MaxMatchSegmentation heap-based overflow

    A weakness has been identified in BYVoid OpenCC up to 1.1.9. This vulnerability affects the function opencc::MaxMatchSegmentation of the file src/MaxMatchSegmentation.cpp. This manipulation causes heap-based buffer overflow. The attack is restricted to local execution. The exploit has been made available to the public and could be used for attacks. Patch name: 345c9a50ab07018f1b4439776bad78a0d40778ec. To fix this issue, it is recommended to deploy a patch.

    • Update to 1.2.0
    Published Updated
  3. CVE-2018-16982

    Medium · CVSS 5.5EPSS 1.09%Fix available

    CVE-2018-16982

    Open Chinese Convert (OpenCC) 1.0.5 allows attackers to cause a denial of service (segmentation fault) because BinaryDict::NewFromFile in BinaryDict.cpp may have out-of-bounds keyOffset and valueOffset values via a crafted .ocd file.

    • Update to 1.1.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →