p PatchFirst

PatchFirst · Latest vulnerabilities

pannellum vulnerabilities

Vulnerabilities published for pannellum in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. CVE-2026-27210

    Medium · CVSS 5.3EPSS 0.37%Fix available

    Pannellum has a XSS vulnerability in hot spot attributes

    Pannellum is a lightweight, free, and open source panorama viewer for the web. In versions 3.5.0 through 2.5.6, the hot spot attributes configuration property allowed any attribute to be set, including HTML event handler attributes, allowing for potential XSS attacks. This affects websites hosting the standalone viewer HTML file and any other use of untrusted JSON config files (bypassing the protections of the escapeHTML parameter). As certain events fire without any additional user interaction, visiting a standalone viewer URL that points to a malicious config file — without additional user interaction — is sufficient to trigger the vulnerab

    • Update to 2.5.7
    Published Updated
  2. CVE-2019-16763

    Medium · CVSS 4.8EPSS 0.7%Fix available

    XSS in Pannellum from 2.5.0 through 2.5.4

    In Pannellum from 2.5.0 through 2.5.4 URLs were not sanitized for data URIs (or vbscript:), allowing for potential XSS attacks. Such an attack would require a user to click on a hot spot to execute and would require an attacker-provided configuration. The most plausible potential attack would be if pannellum.htm was hosted on a domain that shared cookies with the targeted site's user authentication; an <iframe> could then be embedded on the attacker's site using pannellum.htm from the targeted site, which would allow the attacker to potentially access information from the targeted site as the authenticated user (or worse if the targeted

    • Update to 2.5.5
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →