p PatchFirst

PatchFirst · Latest vulnerabilities

react-dev-utils vulnerabilities

Vulnerabilities published for react-dev-utils in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 3

  1. CVE-2026-14802

    Medium · CVSS 6.9EPSS 2.11%No fix published

    react create-react-app react-dev-utils openBrowser.js startBrowserProcess os command injection

    A vulnerability was detected in react create-react-app up to 5.0.1 on macOS. This affects the function startBrowserProcess of the file openBrowser.js of the component react-dev-utils. Performing a manipulation results in os command injection. Remote exploitation of the attack is possible. The exploit is now public and may be used. The project was informed of the problem early through an issue report but has not responded yet.

    Published Updated
  2. CVE-2021-24033

    Medium · CVSS 5.6EPSS 3.29%Fix available

    CVE-2021-24033

    react-dev-utils prior to v11.0.4 exposes a function, getProcessForPort, where an input argument is concatenated into a command string to be executed. This function is typically used from react-scripts (in Create React App projects), where the usage is safe. Only when this function is manually invoked with user-provided values (ie: by custom code) is there the potential for command injection. If you're consuming it from react-scripts then this issue does not affect you.

    • Update to 11.0.4
    Published Updated
  3. CVE-2018-6342

    Critical · CVSS 9.8EPSS 2.84%Fix available

    CVE-2018-6342

    react-dev-utils on Windows allows developers to run a local webserver for accepting various commands, including a command to launch an editor. The input to that command was not properly sanitized, allowing an attacker who can make a network request to the server (either via CSRF or by direct request) to execute arbitrary commands on the targeted system. This issue affects multiple branches: 1.x.x prior to 1.0.4, 2.x.x prior to 2.0.2, 3.x.x prior to 3.1.2, 4.x.x prior to 4.2.2, and 5.x.x prior to 5.0.2.

    • Update to 1.0.4
    • Update to 2.0.2
    • Update to 3.1.2
    • Update to 4.2.2
    • Update to 5.0.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →