p PatchFirst

PatchFirst · Latest vulnerabilities

servify-express vulnerabilities

Vulnerabilities published for servify-express in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2025-67731

    High · CVSS 8.7EPSS 0.4%Fix available

    Servify Express does not enforce rate limiting when parsing JSON

    Servify Express is a Node.js package to start an Express server and log the port it's running on. Prior to 1.2, the Express server used express.json() without a size limit, which could allow attackers to send extremely large request bodies. This can cause excessive memory usage, degraded performance, or process crashes, resulting in a Denial of Service (DoS). Any application using the JSON parser without limits and exposed to untrusted clients is affected. The issue is not a flaw in Express itself, but in configuration. This issue is fixed in version 1.2. To work around, consider adding a limit option to the JSON parser, rate limiting at the

    • Update to 1.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →