p PatchFirst

PatchFirst · Latest vulnerabilities

snyk-go-plugin vulnerabilities

Vulnerabilities published for snyk-go-plugin in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2022-40764

    High · CVSS 7.8EPSS 0.61%Fix available

    CVE-2022-40764

    Snyk CLI before 1.996.0 allows arbitrary command execution, affecting Snyk IDE plugins and the snyk npm package. Exploitation could follow from the common practice of viewing untrusted files in the Visual Studio Code editor, for example. The original demonstration was with shell metacharacters in the vendor.json ignore field, affecting snyk-go-plugin before 1.19.1. This affects, for example, the Snyk TeamCity plugin (which does not update automatically) before 20220930.142957.

    • Update to 1.19.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →