p PatchFirst

PatchFirst · Latest vulnerabilities

snyk-gradle-plugin vulnerabilities

Vulnerabilities published for snyk-gradle-plugin in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. CVE-2024-48964

    High · CVSS 7.5EPSS 0.47%Fix available

    CVE-2024-48964

    The package Snyk CLI before 1.1294.0 is vulnerable to Code Injection when scanning an untrusted Gradle project. The vulnerability can be triggered if Snyk test is run inside the untrusted project due to the improper handling of the current working directory name. Snyk recommends only scanning trusted projects.

    • Update to 4.5.0
    Published Updated
  2. CVE-2022-22984

    Medium · CVSS 5EPSS 3.12%Fix available

    Command Injection

    The package snyk before 1.1064.0; the package snyk-mvn-plugin before 2.31.3; the package snyk-gradle-plugin before 3.24.5; the package @snyk/snyk-cocoapods-plugin before 2.5.3; the package snyk-sbt-plugin before 2.16.2; the package snyk-python-plugin before 1.24.2; the package snyk-docker-plugin before 5.6.5; the package @snyk/snyk-hex-plugin before 1.1.6 are vulnerable to Command Injection due to an incomplete fix for [CVE-2022-40764](https://security.snyk.io/vuln/SNYK-JS-SNYK-3037342). A successful exploit allows attackers to run arbitrary commands on the host system where the Snyk CLI is installed by passing in crafted command line flags.

    • Update to 3.24.5
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →