p PatchFirst

PatchFirst · Latest vulnerabilities

vega-expression vulnerabilities

Vulnerabilities published for vega-expression in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2025-59840

    High · CVSS 8.1EPSS 0.42%Fix available

    Vega Cross-Site Scripting (XSS) via expressions abusing toString calls in environments using the VEGA_DEBUG global variable

    Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. In Vega prior to version 6.2.0, applications meeting 2 conditions are at risk of arbitrary JavaScript code execution, even if "safe mode" expressionInterpreter is used. They are vulnerable if they use `vega` in an application that attaches `vega` library and a `vega.View` instance similar to the Vega Editor to the global `window` and if they allow user-defined Vega `JSON` definitions (vs JSON that was is only provided through source code). Patches are available in the following Vega applications. If using the latest Vega

    • Update to 5.2.1
    • Update to 6.1.0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →