openSUSE-SU-2025:15819-1
openSUSE-SU-2025:15819-1 · libruby4_0-4_0-4.0.0~preview2-1.1 on GA media
This page contains facts from public vulnerability sources. Check the original advisory before updating.
These are all security issues fixed in the libruby4_0-4_0-4.0.0~preview2-1.1 package on the GA media of openSUSE Tumbleweed.
Fix available
- Published
- Updated
Stack: system
Affected products and versions
ruby4.0 openSUSE:Tumbleweed
- Affected ranges
- ECOSYSTEM: < 4.0.0~preview2-1.1
Update to 4.0.0~preview2-1.1
Original sources
- https://www.suse.com/security/cve/CVE-2020-10663
- https://www.suse.com/security/cve/CVE-2020-10933
- https://www.suse.com/security/cve/CVE-2021-28965
- https://www.suse.com/security/cve/CVE-2021-31799
- https://www.suse.com/security/cve/CVE-2021-31810
- https://www.suse.com/security/cve/CVE-2021-32066
- https://www.suse.com/security/cve/CVE-2021-41816
- https://www.suse.com/security/cve/CVE-2021-41817
- https://www.suse.com/security/cve/CVE-2021-41819
- https://www.suse.com/security/cve/CVE-2022-28738
- https://www.suse.com/security/cve/CVE-2022-28739
- https://www.suse.com/security/cve/CVE-2023-28755
- https://osv.dev/vulnerability/openSUSE-SU-2025:15819-1