p PatchFirst

PatchFirst · Latest vulnerabilities

amphp/http-server vulnerabilities

Vulnerabilities published for amphp/http-server in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. GHSA-8grv-jq2g-cfhw

    Medium · CVSS 5.3Fix available

    amphp/http-server affected by HTTP/2 DDoS vulnerability

    Versions of `amphp/http-server` prior to `3.4.4` for the 3.x release branch and prior to `2.1.10` for the 2.x release branch are vulnerable to the HTTP/2 "MadeYouReset" DoS attack described by CVE-2025-8671 and https://kb.cert.org/vuls/id/767506. In versions `3.4.4` and `2.1.10`, stream reset protection has been refactored to account for the number of reset streams within a sliding time window. Note that your application must expose HTTP/2 connections directly to be affected by this vulnerability. Servers behind a proxy using HTTP/1.x such as nginx are not affected.

    • Update to 2.1.10
    • Update to 3.4.4
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →