p PatchFirst

PatchFirst · Latest vulnerabilities

doctrine/orm vulnerabilities

Vulnerabilities published for doctrine/orm in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 3

  1. GHSA-6q9v-4hq6-5m67

    Not ratedFix available

    Doctrine SQL injection vulnerability

    Doctrine is prone to SQL injection vulnerability. Users of Doctrine 1.2 and 2 should update to the newly released versions of both libraries immediately. Both versions only include the security fix and no other changes to their previous versions 1.2.3 and 2.0.2. Affected versions are: - 1.2.3 and earlier for PostgreSQL and DB2 Dialects - 2.0.2 and earlier The security issue was found to affect the `Doctrine\DBAL\Platforms\AbstractPlatform::modifyLimitQuery()` function which does not cast input values for limit and offset to integer and allows malicious SQL to be executed if these parameters are passed into Doctrine 2 directly from request v

    • Update to 1.2.4
    • Update to 2.0.3
    Published Updated
  2. CVE-2015-5723

    High · CVSS 7.8EPSS 0.38%Fix available

    CVE-2015-5723

    Doctrine Annotations before 1.2.7, Cache before 1.3.2 and 1.4.x before 1.4.2, Common before 2.4.3 and 2.5.x before 2.5.1, ORM before 2.4.8 or 2.5.x before 2.5.1, MongoDB ODM before 1.0.2, and MongoDB ODM Bundle before 3.0.1 use world-writable permissions for cache directories, which allows local users to execute arbitrary PHP code with additional privileges by leveraging an application with the umask set to 0 and that executes cache entries as code.

    • Update to 2.5.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →