p PatchFirst

PatchFirst · Latest vulnerabilities

getgrav/grav 2.0.14: known vulnerabilities

Known vulnerabilities affecting getgrav/grav 2.0.14: 13. Compare the fixes below with your installed release.

Filter vulnerabilities
Clear filters

Vulnerabilities: 13

  1. CVE-2026-86197

    Medium · CVSS 5.1EPSS 0.41%Fix available

    Grav before 2.0.20 Cross-Site Scripting via Assets Sandbox

    Grav before 2.0.20 contains a cross-site scripting vulnerability in the Twig sandbox policy that allowlists addJs and addCss methods on Grav\Common\Assets without proper output escaping. Page editors can inject arbitrary script by registering malicious assets or injecting attributes, which are rendered unescaped into document head tags and executed for all visitors including administrators.

    • Update to 2.0.20
    Published Updated
  2. CVE-2026-76846

    High · CVSS 8.7EPSS 0.3%Fix available

    Grav before 2.0.16 Information Disclosure via Twig Sandbox

    Grav before 2.0.16 contains an incomplete default denylist in the Twig sandbox configuration that fails to block access to system configuration secrets. Attackers with page-edit permission can use config.get() or config.toArray() in Twig templates to retrieve sensitive values like system.cache.redis.password when config_access is enabled.

    • Update to 2.0.16
    Published Updated
  3. CVE-2026-76839

    High · CVSS 8.7EPSS 0.34%Fix available

    Grav before 2.0.16 Information Disclosure via offsetGet

    Grav before 2.0.16 allows sandboxed Twig templates to access sensitive User fields through allow-listed offsetGet() and offsetexists() methods that lack field filtering. Attackers with page-edit permissions can call offsetGet() on User objects to extract hashed passwords and 2FA secrets, enabling offline password cracking and authentication bypass.

    • Update to 2.0.16
    Published Updated
  4. CVE-2026-72702

    Critical · CVSS 9.3EPSS 0.15%Fix available

    Grav CMS before 2.0.16 Origin Validation Bypass via Referer

    Grav CMS before 2.0.16 contains an origin validation bypass in the Uri::referrer() and Pages::referrerRoute() methods, which validate the Referer header using an unanchored string prefix match (str_starts_with($referrer, $base)) with no trailing delimiter. An attacker who controls a domain that begins with the victim site's origin (e.g. https://example.com.attacker.tld) can send a request with such a Referer to be treated as same-origin, bypassing the Referer-based origin check.

    • Update to 2.0.16
    Published Updated
  5. CVE-2026-72701

    Medium · CVSS 6.3EPSS 0.22%Fix available

    Grav CMS before 2.0.16 Timing Attack via verifyNonce

    Grav CMS before 2.0.16 contains a timing vulnerability in Utils::verifyNonce() that uses non-constant-time string comparison with the === operator instead of hash_equals() for CSRF nonce validation. Attackers can measure response timing differences to recover valid nonce values byte-by-byte through multiple requests, weakening CSRF protection below its intended security margin.

    • Update to 2.0.16
    Published Updated
  6. CVE-2026-72698

    High · CVSS 7.1EPSS 0.41%Fix available

    Grav CMS before 2.0.16 Information Disclosure via Twig Sandbox Bypass

    Grav CMS before 2.0.16 fails to filter system, site, and theme configuration arrays in sandboxed Twig renders, allowing content editors to read sensitive configuration values. Attackers with page-content edit access can access raw configuration arrays including secrets like cache credentials by using dot notation in Twig templates, bypassing the config_denied_paths restrictions.

    • Update to 2.0.16
    Published Updated
  7. CVE-2026-72697

    High · CVSS 7.1EPSS 0.38%Fix available

    Grav CMS before 2.0.16 Path Traversal via media_directory

    Grav CMS before 2.0.16 contains a path traversal vulnerability in the media_directory() Twig function that fails to validate filesystem paths, allowing authenticated users to enumerate and access files outside intended scope. Attackers with page authoring privileges can supply arbitrary filesystem paths to media_directory() and use the allow-listed filepath accessor on Medium objects to read file contents of any file matching configured media extensions that the web server process can access.

    • Update to 2.0.16
    Published Updated
  8. CVE-2026-72695

    High · CVSS 7.1EPSS 0.63%Fix available

    Grav before 2.0.16 Path Traversal via MediaUploadTrait deleteFile

    Grav before 2.0.16 contains a path traversal vulnerability in MediaUploadTrait::deleteFile() that allows authenticated users with media management permissions to delete arbitrary files by supplying filenames with directory traversal sequences. The method validates only the basename portion of the filename while preserving unvalidated directory paths containing ../ sequences that are passed to unlink(), enabling deletion of files outside the intended media storage directory.

    • Update to 2.0.16
    Published Updated
  9. CVE-2026-75831

    Medium · CVSS 5.1EPSS 0.35%Fix available

    Grav before 2.0.15 Stored XSS via audio/video source URL

    Grav before 2.0.15 contains a stored cross-site scripting vulnerability in the audio and video media rendering through the sourceParsedownElement method. The media URL fragment is concatenated unescaped into rawHtml source elements, allowing attackers to inject arbitrary HTML and JavaScript that executes in viewers' sessions.

    • Update to 2.0.15
    Published Updated
  10. CVE-2026-75828

    Critical · CVSS 9.3EPSS 0.39%Fix available

    Grav before 2.0.15 Stored XSS via detectXss() Quote Bypass

    Grav before 2.0.15 contains a stored cross-site scripting vulnerability in the detectXss() function where unpaired quotes in unquoted attribute values bypass event-handler detection. Authenticated editors can inject event handlers like onerror= that pass validation and execute in visitor browsers when page content is rendered.

    • Update to 2.0.15
    Published Updated
  11. CVE-2026-75827

    Critical · CVSS 9.3EPSS 0.86%Public exploitFix available

    Grav before 2.0.15 Arbitrary File Write via error_log

    Grav before 2.0.15 contains an arbitrary file write vulnerability in the Blueprint dynamic-data bare-function validation that uses an incomplete denylist instead of a positive allowlist. Attackers with page-edit or blueprint-config access can invoke the error_log function through a data directive to append PHP payloads to web-accessible files, achieving remote code execution.

    • Update to 2.0.15
    Published Updated
  12. CVE-2026-74907

    High · CVSS 8.2EPSS 0.43%Fix available

    Grav before 2.0.15 Path Traversal via plugin-asset-map.php

    Grav before 2.0.15 contains a path traversal vulnerability in the static asset server within index.php that uses string prefix matching instead of directory-boundary validation. Unauthenticated attackers can access files in sibling directories by exploiting directory names that extend the base path string, such as requesting assets-secret when assets is the configured base.

    • Update to 2.0.15
    Published Updated
  13. CVE-2023-31506

    Medium · CVSS 5.4EPSS 1%No fix published

    CVE-2023-31506

    A cross-site scripting (XSS) vulnerability in Grav versions 1.7.44 and before, allows remote authenticated attackers to execute arbitrary web scripts or HTML via the onmouseover attribute of an ISINDEX element.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →