p PatchFirst

PatchFirst · Latest vulnerabilities

grumpydictator/firefly-iii vulnerabilities · Page 2

Vulnerabilities published for grumpydictator/firefly-iii in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 26

  1. CVE-2019-13647

    Medium · CVSS 5.4EPSS 0.76%Fix available

    CVE-2019-13647

    Firefly III before 4.7.17.3 is vulnerable to stored XSS due to lack of filtration of user-supplied data in image file content. The JavaScript code is executed during attachments/view/$file_id$ attachment viewing. NOTE: It is asserted that an attacker must have the same access rights as the user in order to be able to execute the vulnerability

    • Update to 4.7.17.3
    Published Updated
  2. CVE-2019-13645

    Medium · CVSS 5.4EPSS 0.76%Fix available

    CVE-2019-13645

    Firefly III before 4.7.17.3 is vulnerable to stored XSS due to lack of filtration of user-supplied data in image file names. The JavaScript code is executed during attachments/edit/$file_id$ attachment editing. NOTE: It is asserted that an attacker must have the same access rights as the user in order to be able to execute the vulnerability

    • Update to 4.7.17.3
    Published Updated
  3. CVE-2019-13644

    Medium · CVSS 5.4EPSS 0.76%Fix available

    CVE-2019-13644

    Firefly III before 4.7.17.1 is vulnerable to stored XSS due to lack of filtration of user-supplied data in a budget name. The JavaScript code is contained in a transaction, and is executed on the tags/show/$tag_number$ tag summary page. NOTE: It is asserted that an attacker must have the same access rights as the user in order to be able to execute the vulnerability

    • Update to 4.7.17.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →