p PatchFirst

PatchFirst · Latest vulnerabilities

librenms/librenms vulnerabilities · Page 5

Vulnerabilities published for librenms/librenms in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 106

  1. CVE-2020-35700

    High · CVSS 8.8EPSS 2.34%Fix available

    CVE-2020-35700

    A second-order SQL injection issue in Widgets/TopDevicesController.php (aka the Top Devices dashboard widget) of LibreNMS before 21.1.0 allows remote authenticated attackers to execute arbitrary SQL commands via the sort_order parameter against the /ajax/form/widget-settings endpoint.

    • Update to 21.1.0
    Published Updated
  2. CVE-2019-12465

    High · CVSS 8.1EPSS 1.2%Fix available

    CVE-2019-12465

    An issue was discovered in LibreNMS 1.50.1. A SQL injection flaw was identified in the ajax_rulesuggest.php file where the term parameter is used insecurely in a database query for showing columns of a table, as demonstrated by an ajax_rulesuggest.php?debug=1&term= request.

    • Update to 1.53
    Published Updated
  3. CVE-2019-12464

    High · CVSS 7.5EPSS 2.17%Fix available

    CVE-2019-12464

    An issue was discovered in LibreNMS 1.50.1. An authenticated user can perform a directory traversal attack against the /pdf.php file with a partial filename in the report parameter, to cause local file inclusion resulting in code execution.

    • Update to 1.53
    Published Updated
  4. CVE-2019-12463

    High · CVSS 8.8EPSS 1.39%Fix available

    CVE-2019-12463

    An issue was discovered in LibreNMS 1.50.1. The scripts that handle graphing options (includes/html/graphs/common.inc.php and includes/html/graphs/graphs.inc.php) do not sufficiently validate or encode several fields of user supplied input. Some parameters are filtered with mysqli_real_escape_string, which is only useful for preventing SQL injection attacks; other parameters are unfiltered. This allows an attacker to inject RRDtool syntax with newline characters via the html/graph.php and html/graph-realtime.php scripts. RRDtool syntax is quite versatile and an attacker could leverage this to perform a number of attacks, including disclosing

    • Update to 1.53
    Published Updated
  5. CVE-2019-10671

    High · CVSS 8.8EPSS 1.35%Fix available

    CVE-2019-10671

    An issue was discovered in LibreNMS through 1.47. It does not parameterize all user supplied input within database queries, resulting in SQL injection. An authenticated attacker can subvert these database queries to extract or manipulate data, as demonstrated by the graph.php sort parameter.

    • Update to 1.50.1
    Published Updated
  6. CVE-2019-10668

    Critical · CVSS 9.1EPSS 1.6%Fix available

    CVE-2019-10668

    An issue was discovered in LibreNMS through 1.47. A number of scripts import the Authentication libraries, but do not enforce an actual authentication check. Several of these scripts disclose information or expose functions that are of a sensitive nature and are not expected to be publicly accessible.

    • Update to 1.50.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →