p PatchFirst

PatchFirst · Latest vulnerabilities

librenms/librenms vulnerabilities · Page 6

Vulnerabilities published for librenms/librenms in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 106

  1. CVE-2019-10665

    Critical · CVSS 9.8EPSS 1.48%No fix published

    CVE-2019-10665

    An issue was discovered in LibreNMS through 1.47. The scripts that handle the graphing options (html/includes/graphs/common.inc.php and html/includes/graphs/graphs.inc.php) do not sufficiently validate or encode several fields of user supplied input. Some parameters are filtered with mysqli_real_escape_string, which is only useful for preventing SQL injection attacks; other parameters are unfiltered. This allows an attacker to inject RRDtool syntax with newline characters via the html/graph.php script. RRDtool syntax is quite versatile and an attacker could leverage this to perform a number of attacks, including disclosing directory structure

    Published Updated
  2. CVE-2018-20434

    Critical · CVSS 9.8EPSS 71.49%Public exploitNo fix published

    CVE-2018-20434

    LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the $_POST['community'] parameter to html/pages/addhost.inc.php during creation of a new device, and then making a /ajax_output.php?id=capture&format=text&type=snmpwalk&hostname=localhost request that triggers html/includes/output/capture.inc.php command mishandling.

    Published Updated
  3. CVE-2018-18478

    Medium · CVSS 6.1EPSS 1.6%Fix available

    CVE-2018-18478

    Persistent Cross-Site Scripting (XSS) issues in LibreNMS before 1.44 allow remote attackers to inject arbitrary web script or HTML via the dashboard_name parameter in the /ajax_form.php resource, related to html/includes/forms/add-dashboard.inc.php, html/includes/forms/delete-dashboard.inc.php, and html/includes/forms/edit-dashboard.inc.php.

    • Update to 1.44
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →