p PatchFirst

PatchFirst · Latest vulnerabilities

limesurvey/limesurvey vulnerabilities

Vulnerabilities published for limesurvey/limesurvey in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 8

  1. CVE-2026-50636

    High · CVSS 8.7EPSS 0.36%No fix published

    LimeSurvey RemoteControl invite_participants/remind_participants SQL Injection

    The RemoteControl API methods invite_participants and remind_participants pass a caller-supplied token-ID array into TokenDynamic::findUninvited(), which concatenates the values directly into a tid IN ('...') SQL clause without parameterization or input validation. A remote, authenticated attacker holding the tokens/update permission on a survey can inject a crafted array element to perform SQL injection. Because LimeSurvey configures its PDO connection with emulated prepared statements (emulatePrepare = true) and does not disable MySQL multi-statements, the injection supports stacked queries: the attacker can append arbitrary additional stat

    Published Updated
  2. CVE-2026-50635

    High · CVSS 8.7EPSS 0.37%No fix published

    LimeSurvey Password Reset Host Header Injection Discloses Reset Token

    LimeSurvey constructs account password-reset links from the client-supplied HTTP Host header without validating it. The optional allowedHosts allowlist that would constrain this is undefined in the default (and documented) configuration, so LSHttpRequest::checkIsAllowedHost() results in no operation. A remote, unauthenticated attacker who submits a forgotten-password request for a known account (requiring only the target's username and email) with a spoofed Host header causes LimeSurvey to email that account a reset link whose hostname is attacker-controlled while embedding the genuine validation_key. When the recipient or an automated inboun

    Published Updated
  3. CVE-2024-28710

    Medium · CVSS 6.1EPSS 0.57%Fix available

    CVE-2024-28710

    Cross Site Scripting vulnerability in LimeSurvey before 6.5.0+240319 allows a remote attacker to execute arbitrary code via a lack of input validation and output encoding in the Alert Widget's message component.

    • Update to 6.5.0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →