p PatchFirst

PatchFirst · Latest vulnerabilities

magento/community-edition vulnerabilities · Page 11

Vulnerabilities published for magento/community-edition in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 360

  1. CVE-2020-24405

    Medium · CVSS 4.3EPSS 1.52%Fix available

    Incorrect permissions in Inventory module could lead to unauthorized modification of inventory stock data

    Magento version 2.4.0 and 2.3.5p1 (and earlier) are affected by an incorrect permissions issue vulnerability in the Inventory module. This vulnerability could be abused by authenticated users to modify inventory stock data without authorization.

    • Update to 2.3.6
    • Update to 2.4.1
    Published Updated
  2. CVE-2020-24403

    Low · CVSS 2.7EPSS 1.63%Fix available

    Incorrect permissions could lead to unauthorized modification of inventory source data via REST API

    Magento version 2.4.0 and 2.3.5p1 (and earlier) are affected by an incorrect user permissions vulnerability within the Inventory component. This vulnerability could be abused by authenticated users with Inventory and Source permissions to make unauthorized changes to inventory source data via the REST API.

    • Update to 2.3.6
    • Update to 2.4.1
    Published Updated
  3. CVE-2020-24401

    Medium · CVSS 6.5EPSS 2.32%Fix available

    Incorrect permissions following the deletion of a user role or deactivation of a user

    Magento versions 2.4.0 and 2.3.5p1 (and earlier) are affected by an incorrect authorization vulnerability. A user can still access resources provisioned under their old role after an administrator removes the role or disables the user's account.

    • Update to 2.4.1
    Published Updated
  4. CVE-2020-24402

    Medium · CVSS 4.9EPSS 1.7%Fix available

    Incorrect permissions in the Integrations component could lead to unauthorized deletion of customer details via REST API

    Magento version 2.4.0 and 2.3.5p1 (and earlier) are affected by an incorrect permissions vulnerability in the Integrations component. This vulnerability could be abused by authenticated users with permissions to the Resource Access API to delete customer details via the REST API without authorization.

    • Update to 2.3.6
    • Update to 2.4.1
    Published Updated
  5. CVE-2020-24400

    High · CVSS 7.1EPSS 2.3%Fix available

    SQL injection allows arbitrary read from database

    Magento versions 2.4.0 and 2.3.5 (and earlier) are affected by an SQL Injection vulnerability that could lead to sensitive information disclosure. This vulnerability could be exploited by an authenticated user with permissions to the product listing page to read data from the database.

    • Update to 2.3.6
    • Update to 2.4.1
    Published Updated
  6. CVE-2020-24408

    Medium · CVSS 6.1EPSS 1.74%Fix available

    Stored XSS in customer address upload feature

    Magento versions 2.4.0 and 2.3.5p1 (and earlier) are affected by a persistent XSS vulnerability that allows users to upload malicious JavaScript via the file upload component. This vulnerability could be abused by an unauthenticated attacker to execute XSS attacks against other Magento users. This vulnerability requires a victim to browse to the uploaded file.

    • Update to 2.4.1
    Published Updated
  7. CVE-2020-9577

    Medium · CVSS 6.1EPSS 1.5%Fix available

    CVE-2020-9577

    Magento versions 2.3.4 and earlier, 2.2.11 and earlier (see note), 1.14.4.4 and earlier, and 1.9.4.4 and earlier have a stored cross-site scripting vulnerability. Successful exploitation could lead to sensitive information disclosure .

    • Update to 2.3.4-p2
    Published Updated
  8. CVE-2020-9588

    High · CVSS 7.2EPSS 2.92%Fix available

    CVE-2020-9588

    Magento versions 2.3.4 and earlier, 2.2.11 and earlier (see note), 1.14.4.4 and earlier, and 1.9.4.4 and earlier have an observable timing discrepancy vulnerability. Successful exploitation could lead to signature verification bypass.

    • Update to 2.3.4-p2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →