p PatchFirst

PatchFirst · Latest vulnerabilities

magento/community-edition vulnerabilities · Page 12

Vulnerabilities published for magento/community-edition in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 360

  1. CVE-2019-8132

    Medium · CVSS 5.4EPSS 0.56%Fix available

    CVE-2019-8132

    A stored cross-site scripting (XSS) vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user can craft malicious payload in the template Name field for Email template in the "Design Configuration" dashboard.

    • Update to 2.2.10
    • Update to 2.3.2-p1
    Published Updated
  2. CVE-2019-8158

    Critical · CVSS 9.8EPSS 1.29%Fix available

    CVE-2019-8158

    An XPath entity injection vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An attacker can craft a GET request to page cache block rendering module that gets passed to XML data processing engine without validation. The crafted key/value GET request data allows an attacker to limited access to underlying XML data.

    • Update to 2.2.10
    • Update to 2.3.2-p2
    Published Updated
  3. CVE-2019-8157

    Medium · CVSS 5.4EPSS 0.59%Fix available

    CVE-2019-8157

    A stored cross-site scripting (XSS) vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user can manipulate downloadable link and cause an invocation of error handling that acceses user input without sanitization.

    • Update to 2.2.10
    • Update to 2.3.2-p1
    Published Updated
  4. CVE-2019-8156

    High · CVSS 7.2EPSS 1.71%Fix available

    CVE-2019-8156

    A server-side request forgery (SSRF) vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with admin privileges to modify store configurations can manipulate the connector api endpoint to enable remote code execution.

    • Update to 2.2.10
    • Update to 2.3.2-p2
    Published Updated
  5. CVE-2019-8159

    High · CVSS 8.8EPSS 3.27%Fix available

    CVE-2019-8159

    A remote code execution vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with system data manipulation privileges can execute aribitrary code through arbitrary file deletion and OS command injection.

    • Update to 2.2.10
    • Update to 2.3.2-p2
    Published Updated
  6. CVE-2019-8232

    Medium · CVSS 6.6EPSS 0.85%Fix available

    CVE-2019-8232

    In Magento prior to 1.9.4.3, Magento prior to 1.14.4.3, Magento 2.2 prior to 2.2.10, and Magento 2.3 prior to 2.3.3 or 2.3.2-p1, an authenticated user with administrative privileges for the import feature can execute arbitrary code through a race condition that allows webserver configuration file modification.

    • Update to 2.2.10
    • Update to 2.3.2-p1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →