p PatchFirst

PatchFirst · Latest vulnerabilities

moodle/moodle vulnerabilities · Page 6

Vulnerabilities published for moodle/moodle in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 437

  1. CVE-2023-35133

    High · CVSS 7.5EPSS 0.83%Fix available

    Moodle: ssrf risk due to insufficient check on the curl blocked hosts

    An issue in the logic used to check 0.0.0.0 against the cURL blocked hosts lists resulted in an SSRF risk. This flaw affects Moodle versions 4.2, 4.1 to 4.1.3, 4.0 to 4.0.8, 3.11 to 3.11.14, 3.9 to 3.9.21 and earlier unsupported versions.

    • Update to 3.11.15
    • Update to 3.9.22
    • Update to 4.0.9
    • Update to 4.1.4
    • Update to 4.2.1
    Published Updated
  2. CVE-2023-35132

    Medium · CVSS 6.3EPSS 0.8%Fix available

    Moodle: minor sql injection risk on mnet sso access control page

    A limited SQL injection risk was identified on the Mnet SSO access control page. This flaw affects Moodle versions 4.2, 4.1 to 4.1.3, 4.0 to 4.0.8, 3.11 to 3.11.14, 3.9 to 3.9.21 and earlier unsupported versions.

    • Update to 3.11.15
    • Update to 3.9.22
    • Update to 4.0.9
    • Update to 4.1.4
    • Update to 4.2.1
    Published Updated
  3. CVE-2021-27131

    Medium · CVSS 5.4EPSS 0.69%No fix published

    CVE-2021-27131

    Moodle 3.10.1 is vulnerable to persistent/stored cross-site scripting (XSS) due to the improper input sanitization on the "Additional HTML Section" via "Header and Footer" parameter in /admin/settings.php. This vulnerability is leading an attacker to steal admin and all user account cookies by storing the malicious XSS payload in Header and Footer. NOTE: this is disputed by the vendor because the "Additional HTML Section" for "Header and Footer" can only be supplied by an administrator, who is intentionally allowed to enter unsanitized input (e.g., site-specific JavaScript).

    Published Updated
  4. CVE-2023-30944

    Medium · CVSS 5.6EPSS 1.14%Fix available

    Moodle: minor sql injection risk in external wiki method for listing pages

    The vulnerability was found Moodle which exists due to insufficient sanitization of user-supplied data in external Wiki method for listing pages. A remote attacker can send a specially crafted request to the affected application and execute limited SQL commands within the application database.

    • Update to 4.2.0-rc2
    Published Updated
  5. CVE-2023-30943

    Medium · CVSS 6.5EPSS 6.83%Public exploitFix available

    Moodle: tinymce loaders susceptible to arbitrary folder creation

    The vulnerability was found Moodle which exists because the application allows a user to control path of the older to create in TinyMCE loaders. A remote user can send a specially crafted HTTP request and create arbitrary folders on the system.

    • Update to 4.2.0-rc2
    Published Updated
  6. CVE-2023-28336

    Medium · CVSS 4.3EPSS 0.74%Fix available

    Moodle: teacher can access names of users they do not have permission to access

    Insufficient filtering of grade report history made it possible for teachers to access the names of users they could not otherwise access.

    • Update to 3.11.13
    • Update to 3.9.20
    • Update to 4.0.7
    • Update to 4.1.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →