p PatchFirst

PatchFirst · Latest vulnerabilities

netcarver/textile vulnerabilities

Vulnerabilities published for netcarver/textile in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. GHSA-95m2-chm4-mq7m

    High · CVSS 7.3Fix available

    PHP-Textile has persistent XSS vulnerability in image link handling

    ### Details Persistent XSS vulnerability in image link handling of PHP-Textile versions 4.1.2 and older, when running the parser in restricted mode. In restricted mode it is expected that the input would be sanitized, allowing user-input (such as user comments) to be parsed and handled safely by the PHP-Textile library. In restricted mode, the version 4.1.2 of the library does not sanitize or validate user-controllable href input in image links, but allows any link protocol or JavaScriptt links to be used. The vulnerability allows an attacker to add malicious JavaScript code to the page which is then executed when an unexpecting user clicks

    • Update to 4.1.3
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →