p PatchFirst

PatchFirst · Latest vulnerabilities

pimcore/pimcore vulnerabilities · Page 7

Vulnerabilities published for pimcore/pimcore in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 135

  1. CVE-2021-23340

    High · CVSS 7.1EPSS 1.32%Fix available

    Local File Inclusion

    This affects the package pimcore/pimcore before 6.8.8. A Local FIle Inclusion vulnerability exists in the downloadCsvAction function of the CustomReportController class (bundles/AdminBundle/Controller/Reports/CustomReportController.php). An authenticated user can reach this function with a GET request at the following endpoint: /admin/reports/custom-report/download-csv?exportFile=&91;filename]. Since exportFile variable is not sanitized, an attacker can exploit a local file inclusion vulnerability.

    • Update to 6.8.8
    Published Updated
  2. CVE-2020-7759

    Medium · CVSS 6.5EPSS 1.36%Fix available

    SQL Injection

    The package pimcore/pimcore from 6.7.2 and before 6.8.3 are vulnerable to SQL Injection in data classification functionality in ClassificationstoreController. This can be exploited by sending a specifically-crafted input in the relationIds parameter as demonstrated by the following request: http://vulnerable.pimcore.example/admin/classificationstore/relations?relationIds=[{"keyId"%3a"''","groupId"%3a"'asd'))+or+1%3d1+union+(select+1,2,3,4,5,6,name,8,password,'',11,12,'',14+from+users)+--+"}]

    • Update to 6.8.3
    Published Updated
  3. CVE-2019-10763

    Medium · CVSS 6.5EPSS 0.87%Fix available

    CVE-2019-10763

    pimcore/pimcore before 6.3.0 is vulnerable to SQL Injection. An attacker with limited privileges (classes permission) can achieve a SQL injection that can lead in data leakage. The vulnerability can be exploited via 'id', 'storeId', 'pageSize' and 'tables' parameters, using a payload for trigger a time based or error based sql injection.

    • Update to 6.3.0
    Published Updated
  4. CVE-2019-16317

    High · CVSS 8.8EPSS 1.7%Fix available

    CVE-2019-16317

    In Pimcore before 5.7.1, an attacker with limited privileges can trigger execution of a .phar file via a phar:// URL in a filename parameter, because PHAR uploads are not blocked and are reachable within the phar://../../../../../../../../var/www/html/web/var/assets/ directory, a different vulnerability than CVE-2019-10867 and CVE-2019-16318.

    • Update to 5.7.1
    Published Updated
  5. CVE-2019-16318

    High · CVSS 8.8EPSS 1.4%Fix available

    CVE-2019-16318

    In Pimcore before 5.7.1, an attacker with limited privileges can bypass file-extension restrictions via a 256-character filename, as demonstrated by the failure of automatic renaming of .php to .php.txt for long filenames, a different vulnerability than CVE-2019-10867 and CVE-2019-16317.

    • Update to 5.7.1
    Published Updated
  6. CVE-2019-10867

    High · CVSS 8.8EPSS 68.87%Public exploitFix available

    CVE-2019-10867

    An issue was discovered in Pimcore before 5.7.1. An attacker with classes permission can send a POST request to /admin/class/bulk-commit, which will make it possible to exploit the unserialize function when passing untrusted values in the data parameter to bundles/AdminBundle/Controller/Admin/DataObject/ClassController.php.

    • Update to 5.7.1
    Published Updated
  7. CVE-2018-14059

    Medium · CVSS 5.4EPSS 3.12%Public exploitFix available

    CVE-2018-14059

    Pimcore allows XSS via Users, Assets, Data Objects, Video Thumbnails, Image Thumbnails, Field-Collections, Objectbrick, Classification Store, Document Types, Predefined Properties, Predefined Asset Metadata, Quantity Value, and Static Routes functions.

    • Update to 5.3.0
    Published Updated
  8. CVE-2014-2921

    Critical · CVSS 9.3EPSS 6.38%Public exploitFix available

    CVE-2014-2921

    The getObjectByToken function in Newsletter.php in the Pimcore_Tool_Newsletter module in pimcore 1.4.9 through 2.0.0 does not properly handle an object obtained by unserializing Lucene search data, which allows remote attackers to conduct PHP object injection attacks and execute arbitrary code via vectors involving a Zend_Pdf_ElementFactory_Proxy object and a pathname with a trailing \0 character.

    • Update to 2.2.0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →