p PatchFirst

PatchFirst · Latest vulnerabilities

psy/psysh vulnerabilities

Vulnerabilities published for psy/psysh in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2026-25129

    Medium · CVSS 6.7EPSS 0.32%Fix available

    PsySH has Local Privilege Escalation via CWD .psysh.php auto-load

    PsySH is a runtime developer console, interactive debugger, and REPL for PHP. Prior to versions 0.11.23 and 0.12.19, PsySH automatically loads and executes a `.psysh.php` file from the Current Working Directory (CWD) on startup. If an attacker can write to a directory that a victim later uses as their CWD when launching PsySH, the attacker can trigger arbitrary code execution in the victim's context. When the victim runs PsySH with elevated privileges (e.g., root), this results in local privilege escalation. This is a CWD configuration poisoning issue leading to arbitrary code execution in the victim user’s context. If a privileged user (e.g.

    • Update to 0.11.23
    • Update to 0.12.19
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →