p PatchFirst

PatchFirst · Latest vulnerabilities

snipe/snipe-it vulnerabilities · Page 3

Vulnerabilities published for snipe/snipe-it in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 81

  1. CVE-2025-65622

    Medium · CVSS 5.4EPSS 0.19%Fix available

    CVE-2025-65622

    Snipe-IT before 8.3.4 allows stored XSS via the Locations "Country" field, enabling a low-privileged authenticated user to inject JavaScript that executes in another user's session.

    • Update to 8.3.4
    Published Updated
  2. CVE-2025-65621

    Medium · CVSS 5.4EPSS 0.17%Fix available

    CVE-2025-65621

    Snipe-IT before 8.3.4 allows stored XSS, allowing a low-privileged authenticated user to inject JavaScript that executes in an administrator's session, enabling privilege escalation.

    • Update to 8.3.4
    Published Updated
  3. CVE-2025-64027

    Medium · CVSS 6.1EPSS 0.25%No fix published

    CVE-2025-64027

    Snipe-IT v8.3.4 (build 20218) contains a reflected cross-site scripting (XSS) vulnerability in the CSV Import workflow. When an invalid CSV file is uploaded, the application returns a progress_message value that is rendered as raw HTML in the admin interface. An attacker can intercept and modify the POST /livewire/update request to inject arbitrary HTML or JavaScript into the progress_message. Because the server accepts the modified input without sanitization and reflects it back to the user, arbitrary JavaScript executes in the browser of any authenticated admin who views the import page. NOTE: this is disputed by the Supplier because the re

    Published Updated
  4. CVE-2024-51093

    High · CVSS 8.7EPSS 0.43%No fix published

    CVE-2024-51093

    Stored Cross-Site Scripting (XSS) vulnerability in Snipe-IT - v7.0.13 allows an attacker to upload a malicious XML file containing JavaScript code. This can lead to privilege escalation when the payload is executed, granting the attacker super admin permissions within the Snipe-IT system.

    Published Updated
  5. CVE-2024-5685

    High · CVSS 7.6EPSS 0.41%Fix available

    Broken Function Level Authorization (BFLA) in snipe/snipe-it

    Users with "User:edit" and "Self:api" permissions can promote or demote themselves or other users by performing changes to the group's memberships via API call.This issue affects snipe-it: from v4.6.17 through v6.4.1.

    • Update to 6.4.2
    Published Updated
  6. CVE-2022-23064

    High · CVSS 8.8EPSS 1.32%Fix available

    Snipe-IT - Host Header Injection

    In Snipe-IT, versions v3.0-alpha to v5.3.7 are vulnerable to Host Header Injection. By sending a specially crafted host header in the reset password request, it is possible to send password reset links to users which once clicked lead to an attacker controlled server and thus leading to password reset token leak. This leads to account take over.

    • Update to 5.3.8
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →