p PatchFirst

PatchFirst · Latest vulnerabilities

symfony/dependency-injection vulnerabilities

Vulnerabilities published for symfony/dependency-injection in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. GHSA-c636-cg5r-2498

    High · CVSS 7.5Fix available

    Symfony XML Entity Expansion security vulnerability

    Symfony 2.0.11 carried a [similar] XXE security fix, however, on review of ZF2 I also noted a vulnerability to XML Entity Expansion (XEE) attacks whereby all extensions making use of libxml2 have no defense against XEE Quadratic Blowup Attacks. The vulnerability is a function of there being no current method of disabling custom entities in PHP (i.e. defined internal to the XML document without using external entities). In a QBA, a long entity can be defined and then referred to multiple times in document elements, creating a memory sink with which Denial Of Service attacks against a host's RAM can be mounted. The use of the LIBXML_NOENT or eq

    • Update to 2.0.17
    Published Updated
  2. CVE-2019-10910

    Critical · CVSS 9.8EPSS 6.02%Fix available

    CVE-2019-10910

    In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, when service ids allow user input, this could allow for SQL Injection and remote code execution. This is related to symfony/dependency-injection.

    • Update to 2.7.51
    • Update to 2.8.50
    • Update to 3.4.26
    • Update to 4.1.12
    • Update to 4.2.7
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →