p PatchFirst

PatchFirst · Latest vulnerabilities

symfony/symfony 8.0.13: known vulnerabilities

Known vulnerabilities affecting symfony/symfony 8.0.13: 2. Compare the fixes below with your installed release.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. CVE-2026-109413

    High · CVSS 8.7EPSS 0.4%Fix available

    Symfony: Unbounded Recursion in the YAML Inline Lexer Lets a Single Document Crash the Process

    In Symfony YAML prior to versions 5.4.54, 6.4.45, 7.4.18, and 8.1.6, Yaml\Parser::lexInlineStructure() recursed through lexInlineMapping() and lexInlineSequence() for every { and [ of an inline collection, without entering the nesting level that the rest of the parser bounds with maxNestingLevel. A document made of deeply nested inline collections, such as [[[[...]]]], exhausted the stack while it was being lexed: depending on the PHP version and its stack settings, the process crashed or the request ended with a fatal error. Any code parsing untrusted YAML is affected. That includes #[MapRequestPayload] when the Yaml component is installe

    • Update to 8.1.6
    Published Updated
  2. CVE-2026-108082

    High · CVSS 8.7EPSS 0.48%Fix available

    Symfony: ReDoS in HeaderUtils::split() Reachable Through the Cache-Control Request Header

    Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to versions 5.4.54, 6.4.46, 7.4.19, and 8.1.7, HeaderUtils::split() parsed header values with a pattern whose token alternative also matched whitespace, followed by a (?<!\s) lookbehind. A run of whitespace placed before a separator could be divided among the iterations of the enclosing repetition in exponentially many ways, and the engine tried all of them before settling. HeaderBag calls it for the Cache-Control header whenever a Request is built, so any application handling HTTP requests is reachable, with no authentication. A single

    • Update to 8.1.7
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →