p PatchFirst

PatchFirst · Latest vulnerabilities

typo3/cms 10.4.32: known vulnerabilities

Known vulnerabilities affecting typo3/cms 10.4.32: 8. Compare the fixes below with your installed release.

Filter vulnerabilities
Clear filters

Vulnerabilities: 8

  1. CVE-2023-24814

    High · CVSS 8.8EPSS 0.83%Fix available

    Persisted Cross-Site Scripting in Frontend Rendering in typo3

    TYPO3 is a free and open source Content Management Framework released under the GNU General Public License. In affected versions the TYPO3 core component `GeneralUtility::getIndpEnv()` uses the unfiltered server environment variable `PATH_INFO`, which allows attackers to inject malicious content. In combination with the TypoScript setting `config.absRefPrefix=auto`, attackers can inject malicious HTML code to pages that have not been rendered and cached, yet. As a result, injected values would be cached and delivered to other website visitors (persisted cross-site scripting). Individual code which relies on the resolved value of `GeneralUtili

    • Update to 10.4.35
    Published Updated
  2. CVE-2022-23504

    Medium · CVSS 5.7EPSS 0.55%Fix available

    TYPO3 contains Sensitive Information Disclosure via YAML Placeholder Expressions in Site Configuration

    TYPO3 is an open source PHP based web content management system. Versions prior to 9.5.38, 10.4.33, 11.5.20, and 12.1.1 are subject to Sensitive Information Disclosure. Due to the lack of handling user-submitted YAML placeholder expressions in the site configuration backend module, attackers could expose sensitive internal information, such as system configuration or HTTP request messages of other website visitors. A valid backend user account having administrator privileges is needed to exploit this vulnerability. This issue has been patched in versions 9.5.38 ELTS, 10.4.33, 11.5.20, 12.1.1.

    • Update to 10.4.33
    Published Updated
  3. CVE-2022-23503

    High · CVSS 7.5EPSS 0.84%Fix available

    TYPO3 vulnerable to Arbitrary Code Execution via Form Framework

    TYPO3 is an open source PHP based web content management system. Versions prior to 8.7.49, 9.5.38, 10.4.33, 11.5.20, and 12.1.1 are vulnerable to Code Injection. Due to the lack of separating user-submitted data from the internal configuration in the Form Designer backend module, it is possible to inject code instructions to be processed and executed via TypoScript as PHP code. The existence of individual TypoScript instructions for a particular form item and a valid backend user account with access to the form module are needed to exploit this vulnerability. This issue is patched in versions 8.7.49 ELTS, 9.5.38 ELTS, 10.4.33, 11.5.20, 12.1.1

    • Update to 10.4.33
    Published Updated
  4. CVE-2022-23502

    Medium · CVSS 5.4EPSS 0.43%Fix available

    TYPO3 contains Insufficient Session Expiration after Password Reset

    TYPO3 is an open source PHP based web content management system. In versions prior to 10.4.33, 11.5.20, and 12.1.1, When users reset their password using the corresponding password recovery functionality, existing sessions for that particular user account were not revoked. This applied to both frontend user sessions and backend user sessions. This issue is patched in versions 10.4.33, 11.5.20, 12.1.1.

    • Update to 10.4.33
    Published Updated
  5. CVE-2022-23501

    Medium · CVSS 5.9EPSS 0.51%Fix available

    TYPO3 vulnerable to Improper Authentication in Frontend Login

    TYPO3 is an open source PHP based web content management system. In versions prior to 8.7.49, 9.5.38, 10.4.33, 11.5.20, and 12.1.1 TYPO3 is vulnerable to Improper Authentication. Restricting frontend login to specific users, organized in different storage folders (partitions), can be bypassed. A potential attacker might use this ambiguity in usernames to get access to a different account - however, credentials must be known to the adversary. This issue is patched in versions 8.7.49 ELTS, 9.5.38 ELTS, 10.4.33, 11.5.20, 12.1.1.

    • Update to 10.4.33
    Published Updated
  6. CVE-2022-23500

    Medium · CVSS 5.9EPSS 0.73%Fix available

    TYPO3 subject to Uncontrolled Recursion resulting in Denial of Service

    TYPO3 is an open source PHP based web content management system. In versions prior to 9.5.38, 10.4.33, 11.5.20, and 12.1.1, requesting invalid or non-existing resources via HTTP triggers the page error handler, which again could retrieve content to be shown as an error message from another page. This leads to a scenario in which the application is calling itself recursively - amplifying the impact of the initial attack until the limits of the web server are exceeded. This vulnerability is very similar, but not identical, to the one described in CVE-2021-21359. This issue is patched in versions 9.5.38 ELTS, 10.4.33, 11.5.20 or 12.1.1.

    • Update to 10.4.33
    Published Updated
  7. CVE-2022-23499

    Medium · CVSS 6.1EPSS 0.47%Fix available

    Cross-Site Scripting Protection bypass in HTML Sanitizer

    HTML sanitizer is written in PHP, aiming to provide XSS-safe markup based on explicitly allowed tags, attributes and values. In versions prior to 1.5.0 or 2.1.1, malicious markup used in a sequence with special HTML CDATA sections cannot be filtered and sanitized due to a parsing issue in the upstream package masterminds/html5. This allows bypassing the cross-site scripting mechanism of typo3/html-sanitizer. The upstream package masterminds/html5 provides HTML raw text elements (`script`, `style`, `noframes`, `noembed` and `iframe`) as DOMText nodes, which were not processed and sanitized further. None of the mentioned elements were defined

    • Update to 10.4.33
    Published Updated
  8. CVE-2009-0816

    Not ratedEPSS 1.06%No fix published

    CVE-2009-0816

    Multiple cross-site scripting (XSS) vulnerabilities in the backend user interface in TYPO3 3.3.x through 3.8.x, 4.0 before 4.0.12, 4.1 before 4.1.10, 4.2 before 4.2.6, and 4.3alpha1 allow remote attackers to inject arbitrary web script or HTML via unspecified fields.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →