p PatchFirst

PatchFirst · Latest vulnerabilities

yiisoft/yii2-authclient vulnerabilities

Vulnerabilities published for yiisoft/yii2-authclient in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. CVE-2023-50714

    Medium · CVSS 6.8EPSS 0.49%Fix available

    The Oauth2 PKCE implementation is vulnerable

    yii2-authclient is an extension that adds OpenID, OAuth, OAuth2 and OpenId Connect consumers for the Yii framework 2.0. In yii2-authclient prior to version 2.2.15, the Oauth2 PKCE implementation is vulnerable in 2 ways. First, the `authCodeVerifier` should be removed after usage (similar to `authState`). Second, there is a risk for a `downgrade attack` if PKCE is being relied on for CSRF protection. Version 2.2.15 contains a patch for the issue. No known workarounds are available.

    • Update to 2.2.15
    Published Updated
  2. CVE-2023-50708

    Medium · CVSS 6.1EPSS 0.72%Fix available

    yii2-authclient vulnerable to possible timing attack on string comparison in OAuth1, OAuth2 and OpenID Connect implementation

    yii2-authclient is an extension that adds OpenID, OAuth, OAuth2 and OpenId Connect consumers for the Yii framework 2.0. In yii2-authclient prior to version 2.2.15, the Oauth1/2 `state` and OpenID Connect `nonce` is vulnerable for a `timing attack` since it is compared via regular string comparison (instead of `Yii::$app->getSecurity()->compareString()`). Version 2.2.15 contains a patch for the issue. No known workarounds are available.

    • Update to 2.2.15
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →