p PatchFirst

PatchFirst · Latest vulnerabilities

apache-airflow-providers-celery vulnerabilities

Vulnerabilities published for apache-airflow-providers-celery in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2023-46215

    High · CVSS 7.5EPSS 1.21%Fix available

    Apache Airflow Celery provider, Apache Airflow: Sensitive information logged as clear text when rediss, amqp, rpc protocols are used as Celery result backend

    Insertion of Sensitive Information into Log File vulnerability in Apache Airflow Celery provider, Apache Airflow. Sensitive information logged as clear text when rediss, amqp, rpc protocols are used as Celery result backend Note: the vulnerability is about the information exposed in the logs not about accessing the logs. This issue affects Apache Airflow Celery provider: from 3.3.0 through 3.4.0; Apache Airflow: from 1.10.0 through 2.6.3. Users are recommended to upgrade Airflow Celery provider to version 3.4.1 and Apache Airlfow to version 2.7.0 which fixes the issue.

    • Update to 3.4.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →