p PatchFirst

PatchFirst · Latest vulnerabilities

apache-airflow-providers-edge3 vulnerabilities

Vulnerabilities published for apache-airflow-providers-edge3 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2025-67895

    Critical · CVSS 9.8EPSS 1.17%Fix available

    Apache Airflow Providers Edge3: Edge3 Worker RPC RCE on Airflow 2

    Edge3 Worker RPC RCE on Airflow 2. This issue affects Apache Airflow Providers Edge3: before 2.0.0 - and only if you installed and configured it on Airflow 2. The Edge3 provider support in Airflow 2 has been always development-only and not officially released, however if you installed and configured Edge3 provider in Airflow 2, it implicitly enabled non-public (normally) API which was used to test Edge Provider in Airflow 2 during the development. This API allowed Dag author to perform Remote Code Execution in the webserver context, which Dag Author was not supposed to be able to do. If you installed and configured Edge3 provider for Air

    • Update to 2.0.0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →