p PatchFirst

PatchFirst · Latest vulnerabilities

apache-superset 5.0.0: known vulnerabilities

Known vulnerabilities affecting apache-superset 5.0.0: 4. Compare the fixes below with your installed release.

Filter vulnerabilities
Clear filters

Vulnerabilities: 4

  1. CVE-2026-23980

    Medium · CVSS 5.3EPSS 0.71%Fix available

    Apache Superset: Improper Neutralization of Special Elements used in a SQL Command

    Improper Neutralization of Special Elements used in a SQL Command ('SQL Injection') vulnerability in Apache Superset allows an authenticated user with read access to conduct error-based SQL injection via the sqlExpression or where parameters. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.

    • Update to 6.0.0
    Published Updated
  2. CVE-2026-23982

    High · CVSS 7.1EPSS 0.51%Fix available

    Apache Superset: Improper Authorization in Dataset Creation Allows Access Control Bypass

    An Improper Authorization vulnerability exists in Apache Superset that allows a low-privileged user to bypass data access controls. When creating a dataset, Superset enforces permission checks to prevent users from querying unauthorized data. However, an authenticated attacker with permissions to write datasets and read charts can bypass these checks by overwriting the SQL query of an existing dataset. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.

    • Update to 6.0.0
    Published Updated
  3. CVE-2026-23983

    Low · CVSS 2.3EPSS 0.47%Fix available

    Apache Superset: Sensitive Data Exposure via REST API (disabled by default)

    A Sensitive Data Exposure vulnerability exists in Apache Superset allowing authenticated users to retrieve sensitive user information. The Tag endpoint (disabled by default) allows users to retrieve a list of objects associated with a specific tag. When these associated objects include Users, the API response improperly serializes and returns sensitive fields, including password hashes (pbkdf2), email addresses, and login statistics. This vulnerability allows authenticated users with low privileges (e.g., Gamma role) to view sensitive authentication data This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to

    • Update to 6.0.0
    Published Updated
  4. CVE-2026-23984

    High · CVSS 7.1EPSS 0.41%Fix available

    Apache Superset: SQLLab Read-Only Bypass on PostgreSQL

    An Improper Input Validation vulnerability exists in Apache Superset that allows an authenticated user with SQLLab access to bypass the read-only verification check when using a PostgreSQL database connection. While the system effectively blocks standard Data Manipulation Language (DML) statements (e.g., INSERT, UPDATE, DELETE) on read-only connections, it fails to detect them in specially crafted SQL statements. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.

    • Update to 6.0.0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →