p PatchFirst

PatchFirst · Latest vulnerabilities

cadwyn vulnerabilities

Vulnerabilities published for cadwyn in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2025-53528

    High · CVSS 7.6EPSS 0.28%Fix available

    Cadwyn is vulnerable to an XSS attack through its docs page

    Cadwyn creates production-ready community-driven modern Stripe-like API versioning in FastAPI. In versions before 5.4.3, the version parameter of the "/docs" endpoint is vulnerable to a Reflected XSS (Cross-Site Scripting) attack. This XSS would notably allow an attacker to execute JavaScript code on a user's session for any application based on Cadwyn via a one-click attack. The vulnerability has been fixed in version 5.4.3.

    • Update to 5.4.3
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →