p PatchFirst

PatchFirst · Latest vulnerabilities

cognee vulnerabilities

Vulnerabilities published for cognee in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2026-58473

    Critical · CVSS 9.3EPSS 0.51%Fix available

    Cognee < 1.2.0 Unauthorized LLM Configuration Overwrite via /api/v1/settings

    Cognee before 1.2.0 contains an improper access control vulnerability that allows unauthenticated attackers to overwrite the global LLM provider configuration by self-registering an account and calling the settings endpoint, which performs no admin or superuser check. Attackers can redirect all LLM operations instance-wide to an attacker-controlled endpoint by exploiting the process-wide singleton configuration cache, enabling exfiltration of prompts, uploaded documents, extracted entities, and knowledge graph content from all users.

    • Update to 1.5.0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →