p PatchFirst

PatchFirst · Latest vulnerabilities

deeptutor vulnerabilities

Vulnerabilities published for deeptutor in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2026-58168

    High · CVSS 7.7EPSS 0.41%Fix available

    DeepTutor < 1.4.10 - Insecure Default Grants Unrestricted MCP Tool Access to Non-Admin Users

    DeepTutor before version 1.4.10 contains an authorization bypass vulnerability that allows low-privilege users to invoke unrestricted MCP tools due to the allowed_mcp_tools function returning None instead of a denied result when mcp_tools is omitted from a user's grant in deeptutor/multi_user/tool_access.py. Attackers or prompt-injected content acting within a user session can enumerate and invoke any configured MCP tool, including filesystem, shell, and browser servers, gaining unauthorized access to sensitive deployment resources.

    • Update to 1.4.10
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →