p PatchFirst

PatchFirst · Latest vulnerabilities

djoser vulnerabilities

Vulnerabilities published for djoser in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2024-21543

    Medium · CVSS 5.7EPSS 0.55%Fix available

    CVE-2024-21543

    Versions of the package djoser before 2.3.0 are vulnerable to Authentication Bypass when the authenticate() function fails. This is because the system falls back to querying the database directly, granting access to users with valid credentials, and eventually bypassing custom authentication checks such as two-factor authentication, LDAP validations, or requirements from configured AUTHENTICATION_BACKENDS.

    • Update to 2.3.0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →