p PatchFirst

PatchFirst · Latest vulnerabilities

docling-core vulnerabilities

Vulnerabilities published for docling-core in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 3

  1. CVE-2026-44023

    High · CVSS 8.6EPSS 0.43%Fix available

    Docling Core has unsafe remote filename resolution

    Docling Core defines core data types and transformations for the document processing application Docling. In versions 1.5.0 and above, prior to 2.74.1, docling-core did not sufficiently restrict remote request destinations and could resolve a server-provided Content-Disposition to a local path in an unsafe manner. In applications that accept untrusted URLs, this could allow SSRF attacks targeting local files outside the user-defined cache directory. This issue has been fixed in version 2.74.1.

    • Update to 2.74.1
    Published Updated
  2. CVE-2026-44019

    High · CVSS 8.1EPSS 0.42%Fix available

    Docling Core has insufficient validation of image reference URIs

    Docling Core defines core data types and transformations for the document processing application Docling. In versions 2.5.0 and above, prior to 2.74.1, docling-core could allow local file:// image references and accepted inline data: content without a decoded-size limit. In applications that accept untrusted image references, this may allow access to local files readable by the process or excessive memory use from large inline payloads. This issue has been fixed in version 2.74.1.

    • Update to 2.74.1
    Published Updated
  3. CVE-2026-24009

    High · CVSS 8.1EPSS 1.53%Fix available

    Docling Core vulnerable to Remote Code Execution via unsafe PyYAML usage

    Docling Core (or docling-core) is a library that defines core data types and transformations in the document processing application Docling. A PyYAML-related Remote Code Execution (RCE) vulnerability, namely CVE-2020-14343, is exposed in docling-core starting in version 2.21.0 and prior to version 2.48.4, specifically only if the application uses pyyaml prior to version 5.4 and invokes `docling_core.types.doc.DoclingDocument.load_from_yaml()` passing it untrusted YAML data. The vulnerability has been patched in docling-core version 2.48.4. The fix mitigates the issue by switching `PyYAML` deserialization from `yaml.FullLoader` to `yaml.SafeLo

    • Update to 2.48.4
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →