p PatchFirst

PatchFirst · Latest vulnerabilities

doris-mcp-server vulnerabilities

Vulnerabilities published for doris-mcp-server in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 3

  1. CVE-2025-66336

    High · CVSS 8.1EPSS 0.56%Fix available

    Apache Doris MCP Server: SQL injection leading the authentication bypass

    Apache Doris MCP Server contains a SQL injection vulnerability in a metadata query path. A user-controlled database name is directly interpolated into a SQL query, and the query is executed without passing the caller's authorization context. This may allow an authenticated attacker, or an anonymous attacker if authentication is disabled, to bypass SQL security validation and access metadata outside the intended database scope. Affected users are recommended to upgrade to Doris version 0.6.1 or later, which fixes the issue.

    • Update to 0.6.1
    Published Updated
  2. CVE-2025-66335

    Medium · CVSS 5.3EPSS 0.66%Fix available

    Apache Doris MCP Server: MCP SQL inject

    Apache Doris MCP Server versions earlier than 0.6.1 are affected by an improper neutralization flaw in query context handling that may allow execution of unintended SQL statements and bypass of intended query validation and access restrictions through the MCP query execution interface. Version 0.6.1 and later are not affected.

    • Update to 0.6.1
    Published Updated
  3. CVE-2025-58337

    Medium · CVSS 5.4EPSS 0.37%Fix available

    Apache Doris-MCP-Server: Improper Access Control results in bypassing a "read-only" mode for doris-mcp-server MCP Server

    An attacker with a valid read-only account can bypass Doris MCP Server’s read-only mode due to improper access control, allowing modifications that should have been prevented by read-only restrictions. Impact: Bypasses read-only mode; attackers with read-only access may perform unauthorized modifications. Recommended action for operators: Upgrade to version 0.6.0 as soon as possible (this release contains the fix).

    • Update to 0.6.0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →