p PatchFirst

PatchFirst · Latest vulnerabilities

esphome-device-builder vulnerabilities

Vulnerability published for esphome-device-builder in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. CVE-2026-59177

    High · CVSS 8.8EPSS 1.17%Public exploitFix available

    ESPHome Device Builder allows unauthenticated dashboard access via the HA add-on ingress site bound to all interfaces

    ESPHome Device Builder Dashboard is a dashboard for the ESPHome home management software. Prior to 1.0.10, the `Home Assistant` add-on's trusted `ingress` site binds to `0.0.0.0` while intentionally skipping dashboard authentication because the supervisor is expected to authenticate requests upstream. Host networking, required for mDNS, also binds this no-auth site to the `Home Assistant` host's LAN interface. Any device on that local network can therefore connect directly to the `ingress` port, bypass the supervisor, and obtain the full dashboard without credentials or operator misconfiguration. Dashboard capability includes compile-time Pyt

    • Update to 1.0.10
    Published Updated
  2. CVE-2026-59178

    Critical · CVSS 9.8EPSS 0.78%Fix available

    ESPHome Device Builder: Renamed auth env vars silently disable dashboard authentication on upgrade

    ESPHome Device Builder Dashboard is a dashboard for the ESPHome home management software. Prior to version 1.0.12, the dashboard reads its authentication credentials from `$ESPHOME_USERNAME` and `$ESPHOME_PASSWORD`. Earlier versions, and the legacy `esphome` dashboard, read the bare `$USERNAME` and `$PASSWORD` instead. When the env vars were renamed the bare names were dropped with no fallback, so an operator who had protected their dashboard with `USERNAME` / `PASSWORD` (as the older getting started guide documented) loses authentication on upgrade and the dashboard starts open to anyone who can reach its port. The issue is fixed in 1.0.12.

    • Update to 1.0.12
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →