p PatchFirst

PatchFirst · Latest vulnerabilities

ethyca-fides vulnerabilities · Page 2

Vulnerabilities published for ethyca-fides in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 22

  1. CVE-2023-37481

    Low · CVSS 2.7EPSS 0.7%Fix available

    Fides Webserver Vulnerable to SVG Bomb File Uploads

    Fides is an open-source privacy engineering platform for managing data privacy requests and privacy regulations. The Fides webserver is vulnerable to a type of Denial of Service (DoS) attack. Attackers can exploit this vulnerability to upload zip files containing malicious SVG bombs (similar to a billion laughs attack), causing resource exhaustion in Admin UI browser tabs and creating a persistent denial of service of the 'new connector' page (`datastore-connection/new`). This vulnerability affects Fides versions `2.11.0` through `2.15.1`. Exploitation is limited to users with elevated privileges with the `CONNECTOR_TEMPLATE_REGISTER` scope,

    • Update to 2.16.0
    Published Updated
  2. CVE-2023-36827

    High · CVSS 7.5EPSS 1.49%Fix available

    Fides vulnerable to Path Traversal in Webserver API

    Fides is an open-source privacy engineering platform for managing the fulfillment of data privacy requests in a runtime environment, and the enforcement of privacy regulations in code. A path traversal (directory traversal) vulnerability affects fides versions lower than version `2.15.1`, allowing remote attackers to access arbitrary files on the fides webserver container's filesystem. The vulnerability is patched in fides `2.15.1`. If the Fides webserver API is not directly accessible to attackers and is instead deployed behind a reverse proxy as recommended in Ethyca's security best practice documentation, and the reverse proxy is an AWS a

    • Update to 2.15.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →