p PatchFirst

PatchFirst · Latest vulnerabilities

fastapi-sso vulnerabilities

Vulnerabilities published for fastapi-sso in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2025-14546

    Medium · CVSS 6.9EPSS 0.36%Fix available

    CVE-2025-14546

    Versions of the package fastapi-sso before 0.19.0 are vulnerable to Cross-site Request Forgery (CSRF) due to the improper validation of the OAuth state parameter during the authentication callback. While the get_login_url method allows for state generation, it does not persist the state or bind it to the user's session. Consequently, the verify_and_process method accepts the state received in the query parameters without verifying it against a trusted local value. This allows a remote attacker to trick a victim into visiting a malicious callback URL, which can result in the attacker's account being linked to the victim's internal account.

    • Update to 0.19.0
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →