CVE-2023-34541
Langchain 0.0.171 is vulnerable to Arbitrary code execution in load_prompt.
- Update to 0.0.247
PatchFirst · Latest vulnerabilities
Vulnerabilities published for langchain in the last 30 days: 0. Listed in the KEV catalogue: 0.
Vulnerabilities: 23
Langchain 0.0.171 is vulnerable to Arbitrary code execution in load_prompt.
Langchain before v0.0.225 was discovered to contain a remote code execution (RCE) vulnerability in the component JiraAPIWrapper (aka the JIRA API wrapper). This vulnerability allows attackers to execute arbitrary code via crafted input. As noted in the "releases/tag" reference, a fix is available.
In LangChain through 0.0.131, the LLMMathChain chain allows prompt injection attacks that can execute arbitrary code via the Python exec method.
Check your installed stack and versions against the current vulnerability feeds.