p PatchFirst

PatchFirst · Latest vulnerabilities

langchain vulnerabilities

Vulnerabilities published for langchain in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 23

  1. CVE-2026-55443

    Medium · CVSS 5.1EPSS 0.21%Fix available

    LangChain: Path traversal and sandbox escape in LangChain file-search middleware and loaders

    LangChain is a framework for building agents and LLM-powered applications. Prior to 1.3.9, several LangChain components that resolve filesystem paths or expand search patterns do not consistently confine the resolved path to the intended root directory. Affected behaviors include: a file-search agent middleware that validates a starting directory but not the search pattern or the resolved target of matched files, so glob patterns and symlinks can reach files outside the configured root; prompt- and chain/agent-configuration loaders that accept path fields and resolve them without confining the result to a trusted base or rejecting symlink tar

    • Update to 1.3.9
    Published Updated
  2. CVE-2026-45134

    High · CVSS 7.1EPSS 0.2%Fix available

    LangSmith Client SDK: Public prompt pull deserializes untrusted manifests without trust boundary warning

    LangSmith Client SDKs provide SDK's for interacting with the LangSmith platform. Prior to LangSmith SDK Python 0.8.0 and JS/TS 0.6.0, the LangSmith SDK's prompt pull methods (pull_prompt / pull_prompt_commit in Python, pullPrompt / pullPromptCommit in JS/TS) fetch and deserialize prompt manifests from the LangSmith Hub. These manifests may contain serialized LangChain objects and model configuration that affect runtime behavior. When pulling a public prompt by owner/name identifier, the manifest content is controlled by an external party, but prior versions of the SDK did not distinguish this from pulling a prompt within the caller's own orga

    • Update to 0.3.30
    Published Updated
  3. CVE-2024-8309

    Medium · CVSS 4.9EPSS 13.74%Fix available

    SQL Injection in langchain-ai/langchain

    A vulnerability in the GraphCypherQAChain class of langchain-ai/langchain version 0.2.5 allows for SQL injection through prompt injection. This vulnerability can lead to unauthorized data manipulation, data exfiltration, denial of service (DoS) by deleting all data, breaches in multi-tenant security environments, and data integrity issues. Attackers can create, update, or delete nodes and relationships without proper authorization, extract sensitive data, disrupt services, access data across different tenants, and compromise the integrity of the database.

    • Update to 0.2.0
    Published Updated
  4. CVE-2024-5998

    Medium · CVSS 5.2EPSS 0.36%Fix available

    Deserialization of Untrusted Data in langchain-ai/langchain

    A vulnerability in the FAISS.deserialize_from_bytes function of langchain-ai/langchain allows for pickle deserialization of untrusted data. This can lead to the execution of arbitrary commands via the os.system function. The issue affects the latest version of the product.

    • Update to 0.2.9
    Published Updated
  5. CVE-2024-2965

    Medium · CVSS 4.2EPSS 0.3%Fix available

    Denial-of-Service in LangChain SitemapLoader in langchain-ai/langchain

    A Denial-of-Service (DoS) vulnerability exists in the `SitemapLoader` class of the `langchain-ai/langchain` repository, affecting all versions. The `parse_sitemap` method, responsible for parsing sitemaps and extracting URLs, lacks a mechanism to prevent infinite recursion when a sitemap URL refers to the current sitemap itself. This oversight allows for the possibility of an infinite loop, leading to a crash by exceeding the maximum recursion depth in Python. This vulnerability can be exploited to occupy server socket/port resources and crash the Python process, impacting the availability of services relying on this functionality.

    • Update to 0.2.5
    Published Updated
  6. CVE-2024-3571

    Medium · CVSS 6.5EPSS 1.87%Fix available

    Path Traversal in langchain-ai/langchain

    langchain-ai/langchain is vulnerable to path traversal due to improper limitation of a pathname to a restricted directory ('Path Traversal') in its LocalFileStore functionality. An attacker can leverage this vulnerability to read or write files anywhere on the filesystem, potentially leading to information disclosure or remote code execution. The issue lies in the handling of file paths in the mset and mget methods, where user-supplied input is not adequately sanitized, allowing directory traversal sequences to reach unintended directories.

    • Update to 0.0.353
    Published Updated
  7. CVE-2024-28088

    High · CVSS 8.1EPSS 1.74%Fix available

    CVE-2024-28088

    LangChain through 0.1.10 allows ../ directory traversal by an actor who is able to control the final part of the path parameter in a load_chain call. This bypasses the intended behavior of loading configurations only from the hwchase17/langchain-hub GitHub repository. The outcome can be disclosure of an API key for a large language model online service, or remote code execution. (A patch is available as of release 0.1.29 of langchain-core.)

    • Update to 0.0.339
    • Update to 0.1.11
    Published Updated
  8. CVE-2024-0243

    Low · CVSS 3.7EPSS 0.52%Fix available

    Server-side Request Forgery In Recursive URL Loader

    With the following crawler configuration: ```python from bs4 import BeautifulSoup as Soup url = "https://example.com" loader = RecursiveUrlLoader( url=url, max_depth=2, extractor=lambda x: Soup(x, "html.parser").text ) docs = loader.load() ``` An attacker in control of the contents of `https://example.com` could place a malicious HTML file in there with links like "https://example.completely.different/my_file.html" and the crawler would proceed to download that file as well even though `prevent_outside=True`. https://github.com/langchain-ai/langchain/blob/bf0b3cc0b5ade1fb95a5b1b6fa260e99064c2e22/libs/community/langchain_community/docu

    • Update to 0.1.0
    Published Updated
  9. CVE-2023-32786

    High · CVSS 7.5EPSS 0.71%Fix available

    CVE-2023-32786

    In Langchain through 0.0.155, prompt injection allows an attacker to force the service to retrieve data from an arbitrary URL, essentially providing SSRF and potentially injecting content into downstream tasks.

    • Update to 0.0.329
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →