p PatchFirst

PatchFirst · Latest vulnerabilities

litellm 1.103.0: known vulnerabilities

Known vulnerability affecting litellm 1.103.0: 1. Compare the fixes below with your installed release.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2026-114612

    Critical · CVSS 9.9EPSS 0.32%Public exploitFix available

    LiteLLM: Privilege Escalation to Proxy Admin via Cross-Domain Reuse of the Salt Key

    LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From 1.87.0 until 1.100.4, 1.101.3, 1.102.2, 1.103.1, and 1.104.0-rc.2, the proxy reuses one cryptographic context for at-rest secrets and session tokens, allowing an authenticated internal user to have crafted metadata containing a forged administrator credential encrypted and returned by the API-key flow. Replaying that ciphertext as a bearer token causes the proxy to trust the forged proxy administrator identity, permitting administrative access and arbitrary commands through the MCP stdio endpoint. Versions 1.87.0 through 1.90.x require EXPERIMENTAL_UI_L

    • Update to 1.103.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →