p PatchFirst

PatchFirst · Latest vulnerabilities

mage-ai vulnerabilities

Vulnerabilities published for mage-ai in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 6

  1. CVE-2024-45190

    Medium · CVSS 6.5EPSS 0.86%No fix published

    Mage AI pipeline interaction request remote arbitrary file leak

    Mage AI allows remote users with the "Viewer" role to leak arbitrary files from the Mage server due to a path traversal in the "Pipeline Interaction" request

    Published Updated
  2. CVE-2024-45189

    Medium · CVSS 6.5EPSS 0.88%No fix published

    Mage AI git content request remote arbitrary file leak

    Mage AI allows remote users with the "Viewer" role to leak arbitrary files from the Mage server due to a path traversal in the "Git Content" request

    Published Updated
  3. CVE-2024-45188

    Medium · CVSS 6.5EPSS 0.88%No fix published

    Mage AI file content request remote arbitrary file leak

    Mage AI allows remote users with the "Viewer" role to leak arbitrary files from the Mage server due to a path traversal in the "File Content" request

    Published Updated
  4. CVE-2024-45187

    High · CVSS 7.1EPSS 0.5%No fix published

    Mage AI allows deleted users to use the terminal server with admin access, leading to remote code execution

    Guest users in the Mage AI framework that remain logged in after their accounts are deleted, are mistakenly given high privileges and specifically given access to remotely execute arbitrary code through the Mage AI terminal server

    Published Updated
  5. CVE-2024-8072

    Medium · CVSS 5.3EPSS 0.6%No fix published

    Mage AI allows remote unauthenticated attackers to leak the terminal server command history of arbitrary users

    Mage AI allows remote unauthenticated attackers to leak the terminal server command history of arbitrary users

    Published Updated
  6. CVE-2023-31143

    Medium · CVSS 5.9EPSS 0.66%Fix available

    Mage terminal user authentication not working properly

    mage-ai is an open-source data pipeline tool for transforming and integrating data. Those who use Mage starting in version 0.8.34 and prior to 0.8.72 with user authentication enabled may be affected by a vulnerability. The terminal could be accessed by users who are not signed in or do not have editor permissions. Version 0.8.72 contains a fix for this issue.

    • Update to 0.8.72
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →