p PatchFirst

PatchFirst · Latest vulnerabilities

plone-app-portlets vulnerabilities

Vulnerabilities published for plone-app-portlets in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 2

  1. CVE-2026-57149

    Critical · CVSS 9.9EPSS 0.64%Fix available

    plone.app.portlets Vulnerable to Remote Code Execution via TALES Injection

    plone.app.portlets.portlets provides a Plone-specific user interface for plone.portlets, as well as a standard set of portlets that ship with Plone. Starting in version 5.0.0 and prior to versions 5.0.8, 6.0.4, and 7.0.2, the Classic portlet (plone.app.portlets.portlets.classic) used its user-supplied template/macro fields to build a TALES path expression that was then evaluated by the TAL path() helper. Because the value was interpreted as a full TALES expression, a user able to add or edit a Classic portlet could supply a crafted value that escapes simple path traversal and is evaluated as arbitrary code. This is exploitable by any authenti

    • Update to 5.0.8
    • Update to 6.0.4
    • Update to 7.0.2
    Published Updated
  2. CVE-2026-55248

    Critical · CVSS 9.1EPSS 0.44%Fix available

    plone.app.portlets: Denial of service via RSS feed portlet

    plone.app.portlets provides portlets and a Plone-specific user interface for plone.portlets. Prior to 5.0.8, 6.0.4, and 7.0.2, a member who can add an RSS portlet can set its feed URL to a very large response, causing src/plone/app/portlets/portlets/rss.py to download and retain excessive data in memory and deny service. The same RSS URL handling accepts internal hosts, IP addresses, single-word domains, and explicit ports, allowing server-side requests that can probe internal network services and open ports. A malicious feed item can also supply a JavaScript URL that is retained as the item link and can execute script when used by a victim.

    • Update to 5.0.8
    • Update to 6.0.4
    • Update to 7.0.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →