p PatchFirst

PatchFirst · Latest vulnerabilities

pymonocypher vulnerabilities

Vulnerabilities published for pymonocypher in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2026-53720

    Medium · CVSS 5.1EPSS 0.18%Fix available

    pymonocypher: Potential heap buffer overflow on nb_blocks in argon2i_32 when provided buffer is too small

    pymonocypher uses cython to wrap the Monocypher C library. Prior to version 4.0.2.8, the argon2i_32 implementation does not check the nb_blocks size. If the caller does not provide a sufficiently large buffer based on the API contract, then argon2i_32 will write past the end of the buffer and possibly corrupt the heap. This issue has been patched in version 4.0.2.8.

    • Update to 4.0.2.8
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →