p PatchFirst

PatchFirst · Latest vulnerabilities

pypdf 6.21.0: known vulnerabilities

Known vulnerabilities affecting pypdf 6.21.0: 4. Compare the fixes below with your installed release.

Filter vulnerabilities
Clear filters

Vulnerabilities: 4

  1. CVE-2026-115585

    High · CVSS 7.1EPSS 0.41%Fix available

    pypdf: Possible long runtimes for repeated malformed cross-reference entries (Follow-up)

    pypdf is a free and open-source pure-python PDF library. Prior to 6.21.2, an incomplete remediation for repeated malformed cross-reference entries in GHSA-55h5-xmcq-c37v could still trigger a complete PDF stream reload during each recovery attempt even when a recovery cache was present, causing crafted cross-reference streams to produce long runtimes. This issue is fixed in version 6.21.2.

    • Update to 6.21.2
    Published Updated
  2. CVE-2026-115580

    High · CVSS 7.1EPSS 0.41%Fix available

    pypdf: Possible long runtimes for large xref table header limits

    pypdf is a free and open-source pure-python PDF library. Prior to 6.21.2, an attacker can craft a PDF with a standard cross-reference table whose declared entry count exceeds what the file can contain, causing excessive processing and long runtimes when the file is opened. This issue is fixed in version 6.21.2.

    • Update to 6.21.2
    Published Updated
  3. CVE-2026-115572

    High · CVSS 7.1EPSS 0.38%Fix available

    pypdf: Possible long runtimes for repeated references to the same missing object

    pypdf is a free and open-source pure-python PDF library. Prior to 6.21.2, an attacker can craft a PDF that repeatedly references the same nonexistent indirect object, causing relevant file parts such as pages to trigger repeated full-file recovery loads and long runtimes when accessed. This issue is fixed in version 6.21.2.

    • Update to 6.21.2
    Published Updated
  4. CVE-2026-113786

    Low · CVSS 2.3EPSS 0.38%Fix available

    pypdf: Unvalidated JPEG image data loading

    pypdf is a free and open-source pure-python PDF library. Prior to 6.21.1, an attacker can craft a PDF containing image data labeled with the /DCTDecode filter that causes Pillow to select and invoke an unintended image parser when the image is loaded. Environments without the optional Pillow dependency are not affected. This issue is fixed in version 6.21.1.

    • Update to 6.21.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →