p PatchFirst

PatchFirst · Latest vulnerabilities

pyrage vulnerabilities

Vulnerabilities published for pyrage in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2024-56327

    High · CVSS 7.7EPSS 0.5%Fix available

    Malicious plugin names, recipients, or identities can cause arbitrary binary execution in pyrage

    pyrage is a set of Python bindings for the rage file encryption library (age in Rust). `pyrage` uses the Rust `age` crate for its underlying operations, and `age` is vulnerable to GHSA-4fg7-vxc8-qx5w. All details of GHSA-4fg7-vxc8-qx5w are relevant to `pyrage` for the versions specified in this advisory. See GHSA-4fg7-vxc8-qx5w for full details. Versions of `pyrage` before 1.2.0 lack plugin support and are therefore **not affected**. An equivalent issue was fixed in [the reference Go implementation of age](https://github.com/FiloSottile/age), see advisory GHSA-32gq-x56h-299c. This issue has been addressed in version 1.2.3 and all users are ad

    • Update to 1.2.3
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →