p PatchFirst

PatchFirst · Latest vulnerabilities

qwed vulnerabilities

Vulnerabilities published for qwed in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. CVE-2026-55585

    High · CVSS 8.8EPSS 0.78%Fix available

    QWED: Authenticated Remote Code Execution via Unsafe SymPy `parse_expr()`

    QWED is open-source AI verification infrastructure for deterministic verification of LLM outputs, tool calls, code, schemas, and agent state before production execution. Prior to 5.1.2, the qwed package passes caller-controlled math expressions directly to SymPy parse_expr() without restricted global_dict and local_dict namespaces, allowing Python eval() to resolve builtins and execute arbitrary Python code in the API server process. In src/qwed_new/api/main.py, POST /verify/math is protected by get_current_tenant but accepts any valid tenant API key, reads the expression field, applies only a cosmetic re.sub(r'(\d)(()', r'\1*\2', expression)

    • Update to 5.1.2
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →