p PatchFirst

PatchFirst · Latest vulnerabilities

semantic-router vulnerabilities

Vulnerabilities published for semantic-router in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerability: 1

  1. GHSA-98x5-vq43-vc5p

    Not ratedFix available

    semantic-router exposed to compromised litellm wheel (CVE-2026-42208) via unbounded transitive pin

    ## Impact semantic-router versions 0.1.8 through 0.1.14 declare `litellm>=1.61.3` with no upper bound. During the window in which `litellm==1.82.8` was the latest release on PyPI, a fresh install of any affected semantic-router version could resolve to that compromised wheel. The malicious `litellm==1.82.8` wheel ships a `litellm_init.pth` file that executes on Python interpreter startup — no import required. It collects and exfiltrates: - Process environment variables - AWS / GCP / Azure credentials - SSH keys, Kubernetes configs, shell history - Database credentials and CI/CD secrets - Cryptocurrency wallets Stage-two payload encrypts the

    • Update to 0.1.15
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →