p PatchFirst

PatchFirst · Latest vulnerabilities

vllm vulnerabilities · Page 6

Vulnerabilities published for vllm in the last 30 days: 26. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 111

  1. GHSA-ggpf-24jw-3fcw

    Critical · CVSS 9.8Fix available

    CVE-2025-24357 Malicious model remote code execution fix bypass with PyTorch < 2.6.0

    ## Description https://github.com/vllm-project/vllm/security/advisories/GHSA-rh4j-5rhw-hr54 reported a vulnerability where loading a malicious model could result in code execution on the vllm host. The fix applied to specify `weights_only=True` to calls to `torch.load()` did not solve the problem prior to PyTorch 2.6.0. PyTorch has issued a new CVE about this problem: https://github.com/advisories/GHSA-53q9-r3pm-6pq6 This means that versions of vLLM using PyTorch before 2.6.0 are vulnerable to this problem. ## Background Knowledge When users install VLLM according to the official manual ![image](https://github.com/user-attachments/assets/d

    • Update to 0.8.0
    Published Updated
  2. GHSA-hf3c-wxg2-49q9

    Medium · CVSS 6.5Fix available

    vLLM vulnerable to Denial of Service by abusing xgrammar cache

    ### Impact This report is to highlight a vulnerability in XGrammar, a library used by the structured output feature in vLLM. The XGrammar advisory is here: https://github.com/mlc-ai/xgrammar/security/advisories/GHSA-389x-67px-mjg3 The [xgrammar](https://xgrammar.mlc.ai/docs/) library is the default backend used by vLLM to support structured output (a.k.a. guided decoding). Xgrammar provides a required, built-in cache for its compiled grammars stored in RAM. xgrammar is available by default through the OpenAI compatible API server with both the V0 and V1 engines. A malicious user can send a stream of very short decoding requests with unique

    • Update to 0.8.4
    Published Updated
  3. CVE-2024-9052

    Critical · CVSS 9.8No fix published

    vLLM deserialization vulnerability in vllm.distributed.GroupCoordinator.recv_object

    vllm-project vllm version 0.6.0 contains a vulnerability in the distributed training API. The function vllm.distributed.GroupCoordinator.recv_object() deserializes received object bytes using pickle.loads() without sanitization, leading to a remote code execution vulnerability. ### Maintainer perspective Note that vLLM does NOT use the code as described in the report on huntr. The problem only exists if you use these internal APIs in a way that exposes them to a network as described. The vllm team was not involved in the analysis of this report and the decision to assign it a CVE.

    Published Updated
  4. CVE-2024-11041

    Critical · CVSS 9.8EPSS 1.72%No fix published

    Remote Code Execution in vllm-project/vllm

    vllm-project vllm version v0.6.2 contains a vulnerability in the MessageQueue.dequeue() API function. The function uses pickle.loads to parse received sockets directly, leading to a remote code execution vulnerability. An attacker can exploit this by sending a malicious payload to the MessageQueue, causing the victim's machine to execute arbitrary code.

    Published Updated
  5. CVE-2024-9053

    Critical · CVSS 9.8EPSS 1.38%No fix published

    Remote Code Execution in vllm-project/vllm

    vllm-project vllm version 0.6.0 contains a vulnerability in the AsyncEngineRPCServer() RPC server entrypoints. The core functionality run_server_loop() calls the function _make_handler_coro(), which directly uses cloudpickle.loads() on received messages without any sanitization. This can result in remote code execution by deserializing malicious pickle data.

    Published Updated
  6. CVE-2025-29783

    Critical · CVSS 9.1EPSS 0.73%Fix available

    vLLM Allows Remote Code Execution via Mooncake Integration

    vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. When vLLM is configured to use Mooncake, unsafe deserialization exposed directly over ZMQ/TCP on all network interfaces will allow attackers to execute remote code on distributed hosts. This is a remote code execution vulnerability impacting any deployments using Mooncake to distribute KV across distributed hosts. This vulnerability is fixed in 0.8.0.

    • Update to 0.8.0
    Published Updated
  7. CVE-2025-29770

    Medium · CVSS 6.5EPSS 0.47%Fix available

    vLLM denial of service via outlines unbounded cache on disk

    vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. The outlines library is one of the backends used by vLLM to support structured output (a.k.a. guided decoding). Outlines provides an optional cache for its compiled grammars on the local filesystem. This cache has been on by default in vLLM. Outlines is also available by default through the OpenAI compatible API server. The affected code in vLLM is vllm/model_executor/guided_decoding/outlines_logits_processors.py, which unconditionally uses the cache from outlines. A malicious user can send a stream of very short decoding requests with unique schemas, result

    • Update to 0.8.0
    Published Updated
  8. CVE-2025-25183

    Low · CVSS 2.6EPSS 0.19%Fix available

    vLLM using built-in hash() from Python 3.12 leads to predictable hash collisions in vLLM prefix cache

    vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. Maliciously constructed statements can lead to hash collisions, resulting in cache reuse, which can interfere with subsequent responses and cause unintended behavior. Prefix caching makes use of Python's built-in hash() function. As of Python 3.12, the behavior of hash(None) has changed to be a predictable constant value. This makes it more feasible that someone could try exploit hash collisions. The impact of a collision would be using cache that was generated using different content. Given knowledge of prompts in use and predictable hashing behavior, someo

    • Update to 0.7.2
    Published Updated
  9. CVE-2025-24357

    High · CVSS 7.5EPSS 0.87%Fix available

    vLLM allows a malicious model RCE by torch.load in hf_model_weights_iterator

    vLLM is a library for LLM inference and serving. vllm/model_executor/weight_utils.py implements hf_model_weights_iterator to load the model checkpoint, which is downloaded from huggingface. It uses the torch.load function and the weights_only parameter defaults to False. When torch.load loads malicious pickle data, it will execute arbitrary code during unpickling. This vulnerability is fixed in v0.7.0.

    • Update to 0.7.0
    Published Updated
  10. CVE-2024-8939

    Medium · CVSS 6.2EPSS 0.23%No fix published

    Vllm: denials of service in vllm json web api

    A vulnerability was found in the ilab model serve component, where improper handling of the best_of parameter in the vllm JSON web API can lead to a Denial of Service (DoS). The API used for LLM-based sentence or chat completion accepts a best_of parameter to return the best completion from several options. When this parameter is set to a large value, the API does not handle timeouts or resource exhaustion properly, allowing an attacker to cause a DoS by consuming excessive system resources. This leads to the API becoming unresponsive, preventing legitimate users from accessing the service.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →